View Issue Details

IDProjectCategoryView StatusLast Update
0002239Database Workbench v6Firebird Modulepublic2024-06-03 13:57
ReporterSvein Erling Tysvær Assigned ToMartijn Tonies  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.5.0 
Fixed in Versionv6_next 
Summary0002239: Grant Manager/Role Editor crash/hang when users cannot be fetched due to missing user/password combo in Server Registration
DescriptionAccessing the Grant Manager on DBW 6.5.0 makes the program crash. If I try to access the Role Editor (and not Grant Manager), things hang.

Doing the same on DBW 5.7.6 I get "Your user name and password are not defined." followed by an option to specify user name and password.

Only tested on Firebird 2.5.9
Steps To ReproduceRegister a database with SYSDBA as user and "Prompt for password", then connect and try to access the Grant Manager.
Additional InformationSometimes I can get to the Grant Manager similar to with DBW 5.7.6 by using "Connect As" and specify a user without sysdba privileges when connecting to the database and then use SYSDBA if the Grant Manager asks for user/password (though this does produce "Invalid window handle" when I exit DBW). However, 2 out of 3 times this fails with several error messages or even boxes without text.
TagsNo tags attached.

Activities

Martijn Tonies

2024-05-31 10:07

administrator   ~0000605

This needs more information, I cannot yet reproduce this issue.

Tried connected with SYSDBA user and other user name.

Did you register the server with the SYSDBA user?

Svein Erling Tysvær

2024-06-03 09:28

reporter   ~0000607

Sort of, the server is registered with SYSDBA user, but without password (I don't want to store the SYSDBA password). I could possibly have stored the password temporarily when I registered the server many years ago, but I don't remember what I did in an ancient DBW version.

Issue History

Date Modified Username Field Change
2024-05-31 09:51 Svein Erling Tysvær New Issue
2024-05-31 10:07 Martijn Tonies Assigned To => Martijn Tonies
2024-05-31 10:07 Martijn Tonies Status new => feedback
2024-05-31 10:07 Martijn Tonies Note Added: 0000605
2024-06-03 09:28 Svein Erling Tysvær Note Added: 0000607
2024-06-03 09:28 Svein Erling Tysvær Status feedback => assigned
2024-06-03 11:31 Martijn Tonies Summary The Grant Manager crashes & Role Editor hangs => Grant Manager/Role Editor crash/hang when users cannot be fetched due to missing user/password combo in Server Registration
2024-06-03 13:57 Martijn Tonies Status assigned => resolved
2024-06-03 13:57 Martijn Tonies Resolution open => fixed
2024-06-03 13:57 Martijn Tonies Fixed in Version => v6_next