View Issue Details

IDProjectCategoryView StatusLast Update
0001755Database Workbench v5Data Pump & Comparepublic2020-05-07 11:14
ReporterDoychin Bondzhev Assigned ToMartijn Tonies  
Status closedResolutionfixed 
Product Version5.6.8 
Fixed in Version5.7.2 
Summary0001755: Possible hang on comparing data in tables with compound keys
DescriptionI'm trying to compare two databases which are supposed to be in sync. But when I run compare tool it stops on some tables without any errors and never continues.

I tried leaving it that way for hours and it did not move.

These tables don't contain anything strange so I don't see the reason why it stops.

I tried to restart the process few times and it always stops on the same tables at the same position.

If I ignore these tables it passes but problematic tables might contain some difference that will not be able to see because I had to skip them.
Additional InformationAnything that can give me information regarding the real reason to stop will be helpful.
TagsNo tags attached.


Martijn Tonies

2020-02-03 13:00

administrator   ~0000515

Does this also happen if you only select the problematic tables?

If so, could I get copies of the databases?

Doychin Bondzhev

2020-02-03 17:42

reporter   ~0000517

I test only one of the tables that freezes compare operation and it stops at the same location every time.

There is also one table which passes the compare but when you select to see the difference an error is displayed.

Martijn Tonies

2020-02-04 09:22

administrator   ~0000518

"Can you give me an IP address from where you can connect? I will allow access to databases for that IP address."

it would be easier to have a local copy, is that possible?

Martijn Tonies

2020-02-04 09:53

administrator   ~0000520

"I can give you the exact tables that have problems and you can test only with these tables."

If you can, please do.

Martijn Tonies

2020-05-04 13:55

administrator   ~0000539

Doychin, I've got another customer with a reproducible case he send me, so this is easier to check than remote.

I've got a finger behind the cause. Does your problematic table have a compound primary key?

Doychin Bondzhev

2020-05-04 15:04

reporter   ~0000540

Most of the tables mentioned in my report use compound primary key but from what I see some of them use simple one column key to.

Issue History

Date Modified Username Field Change
2020-02-03 12:09 Doychin Bondzhev New Issue
2020-02-03 13:00 Martijn Tonies Assigned To => Martijn Tonies
2020-02-03 13:00 Martijn Tonies Status new => feedback
2020-02-03 13:00 Martijn Tonies Note Added: 0000515
2020-02-03 14:09 Doychin Bondzhev Status feedback => assigned
2020-02-03 17:42 Doychin Bondzhev Note Added: 0000517
2020-02-04 09:22 Martijn Tonies Note Added: 0000518
2020-02-04 09:53 Martijn Tonies Note Added: 0000520
2020-05-04 13:55 Martijn Tonies Note Added: 0000539
2020-05-04 15:04 Doychin Bondzhev Note Added: 0000540
2020-05-05 11:25 Martijn Tonies Summary When comparing data it stops on some tables and stays there forever. => Possible hang on comparing data in tables with compound keys
2020-05-05 11:40 Martijn Tonies Status assigned => resolved
2020-05-05 11:40 Martijn Tonies Resolution open => fixed
2020-05-05 11:40 Martijn Tonies Fixed in Version => 5.7.2
2020-05-07 11:14 Martijn Tonies Status resolved => closed