View Issue Details

IDProjectCategoryView StatusLast Update
0001638Database Workbench v5MySQL Modulepublic2018-10-22 13:07
ReporterSvein Erling Tysvær Assigned ToMartijn Tonies  
Status closedResolutionfixed 
PlatformUsing MariaDB 10.2.14 
Product Version5.4.4 
Fixed in Version5.4.6 
Summary0001638: Abstract error on first opening of table in specific circumstances
DescriptionWhen I logon to a database and doubleclick to open a table, then I first have to wait a while before getting 'Abstract Error' message.
Additional InformationIt is more irritating and time consuming than a problem, clicking continue and then doubleclick the table again is all that is required.
TagsNo tags attached.


Martijn Tonies

2018-09-17 17:08

administrator   ~0000477

I tried reproducing this on MariaDB 10.2, but couldn't.

What more can you tell me about that database?

Svein Erling Tysvær

2018-09-18 11:39

reporter   ~0000479

If I connect using the user with stored password in DbW (a user with very limited rights), I immediately get

internal error: cannot fetch FK data, target constraint "PRIMARY" not found

when doubleclicking a table. The abstract error occurs (after waiting between 1 and 5 minutes after doubleclicking the table) when I 'connect as' and use a different user.

Martijn Tonies

2018-09-18 11:44

administrator   ~0000480

Hello Svein,

Instead of double clicking, it would be helpfull to expand nodes instead. I take it, you'll get this error when you expand the main 'Constraints' node, not while expanding the Indices node?

Svein Erling Tysvær

2018-09-18 11:53

reporter   ~0000482

Yes, the stored user gets the error immediately when expanding constraints. The other user can see constraints, but after waiting 15 seconds gets the error when trying to expand the indices node (could be that it was accidental that I had to wait a lot longer last time I tried).


Martijn Tonies

2018-09-24 10:13

administrator   ~0000483

Last edited: 2018-09-24 10:35

Hello Svein,

Is there any way I could get (temporary) access to that database?

Martijn Tonies

2018-09-24 10:36

administrator   ~0000484

Alternatively, I can send you a new build that could fix this, interested? If so, send me an e-mail.

Issue History

Date Modified Username Field Change
2018-09-17 10:50 Svein Erling Tysvær New Issue
2018-09-17 17:08 Martijn Tonies Note Added: 0000477
2018-09-17 17:08 Martijn Tonies Assigned To => Martijn Tonies
2018-09-17 17:08 Martijn Tonies Status new => feedback
2018-09-18 11:39 Svein Erling Tysvær Note Added: 0000479
2018-09-18 11:39 Svein Erling Tysvær Status feedback => assigned
2018-09-18 11:44 Martijn Tonies Note Added: 0000480
2018-09-18 11:53 Svein Erling Tysvær Note Added: 0000482
2018-09-24 10:13 Martijn Tonies Note Added: 0000483
2018-09-24 10:35 Martijn Tonies Note Edited: 0000483
2018-09-24 10:36 Martijn Tonies Note Added: 0000484
2018-09-26 11:55 Martijn Tonies Summary Abstract error on first opening of table => Abstract error on first opening of table in specific circumstances
2018-09-26 16:08 Martijn Tonies Status assigned => resolved
2018-09-26 16:08 Martijn Tonies Fixed in Version => 5.4.6
2018-09-26 16:08 Martijn Tonies Resolution open => fixed
2018-10-22 13:07 Martijn Tonies Status resolved => closed